<!DOCTYPE html>
<html lang="en" class="no-js">
  <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" /><script type="text/javascript">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</script>
<meta property="og:type" content="article" />
<meta property="og:url" content="http://wcbe.org/post/comeys-removal-started-whirlwind-week-politics" />
<meta property="og:title" content="Comey&#039;s Removal Started A Whirlwind Week Of Politics" />
<link href="http://mediad.publicbroadcasting.net/spacer.gif" rel="image_src" />
<meta name="description" content="Copyright 2017 NPR. To see more, visit http://www.npr.org/." />
<meta property="og:description" content="Copyright 2017 NPR. To see more, visit http://www.npr.org/." />
<meta property="og:image" content="" />
<meta content="Comey&amp;#039;s Removal Started A Whirlwind Week Of Politics" about="/post/comeys-removal-started-whirlwind-week-politics" property="dc:title" />
<link rel="shortcut icon" href="http://mediad.publicbroadcasting.net/p/wcbe/files/201508/favicon_fid.ico" type="image/vnd.microsoft.icon" />
<meta property="twitter:creator" content="@WCBE905Columbus" />
<meta property="twitter:site" content="@WCBE905Columbus" />
<meta property="twitter:card" content="summary" />
<meta name="datePublished" content="2017-05-13" />
<meta name="story_id" content="528287815" />
<link rel="shortlink" href="/node/107414" />
<meta name="has_audio" content="1" />
<link rel="canonical" href="/post/comeys-removal-started-whirlwind-week-politics" />
<script type="text/javascript">var _sf_startpt=(new Date()).getTime();</script>
<meta name="Generator" content="Drupal 7 (http://drupal.org)" />
<meta name="programs" content="none" />
<meta name="category" content="none" />
<meta name="keywords" content="" />
<meta name="org_id" content="1" />
<meta name="author" content="Ron Elving" />
<meta name="nid" content="107414" />
<meta name="wordCount" content="45" />
    <title>Comey&#039;s Removal Started A Whirlwind Week Of Politics | WCBE 90.5 FM</title>
    <link type="text/css" rel="stylesheet" href="http://wcbe.org/sites/wcbe.org/files/css/css_zXr1pRkjUmFHX10b6Pv5_DqzyewvdLNQ8QgccGQIRQQ.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://wcbe.org/sites/wcbe.org/files/css/css_ZFlaYqkiQzTmlBPX4mQeT33IFQX3nR-zpGlyqFhtTNM.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://wcbe.org/sites/wcbe.org/files/css/css_XHTm2cMU6sD6pzlNwtS19lgDRK8GjAz14nQaxKhle30.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://wcbe.org/sites/wcbe.org/files/css/css_uY1_bHNTrAu2UuUwumZ6AuPc2Egu5fV5FiJ2-fv7ySk.css" media="all" />
<style type="text/css" media="all">
<!--/*--><![CDATA[/*><!--*/
.header-region-outer{background-color:#186A8F;}@media screen and (min-width:1024px){.header-region-outer{background-image:url(http://mediad.publicbroadcasting.net/p/wcbe/files/201508/background_fid.jpg);background-position:center bottom;background-size:cover;background-repeat:no-repeat;}}.branding .tagline{color:#000;}.branding .listen-live-toggle > a,.branding .header-utility > a,.branding .header-utility > a.trigger-nav{color:#DEDEDE;}@media screen and (min-width:641px){.branding .trigger-nav{background:#777777;}}@media screen and (max-width:640px){.branding .header-utility > a.trigger-nav,.active-menu .branding .header-utility > a.trigger-nav{color:#777777;}}#listen-live .listen-live-toggle{background-color:#1E3E4D;}#listen-live .listen-live-btn{background-color:transparent;color:#DEDEDE;}@media screen and (min-width:640px){#listen-live .listen-live-btn{background-color:#1E3E4D;}}.branding .give{background:#A32B19;}

/*]]>*/-->
</style>
<link type="text/css" rel="stylesheet" href="http://fonts.googleapis.com/css?family=Lato:300,700,700italic,900,italic,regular&amp;subset=latin" media="all" />
<link type="text/css" rel="stylesheet" href="http://wcbe.org/sites/wcbe.org/files/css/css_WRSUrWDNbzXQeWepbLhE8tRJalGJkdaXUXq-sgUIXOo.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://wcbe.org/sites/wcbe.org/files/css/css_SWo6tZlpCPjnhbZDAS4xgnCAofi51J7pbtu4SD2fIug.css" media="all" />
    <script type="text/javascript" src="http://mediad.publicbroadcasting.net/p/wcbe/files/js/js_xSpMA4ArVcBKOZ43sPqNRk0gxQZdDVifw27pIUCzWU0.js"></script>
<script type="text/javascript" src="http://mediad.publicbroadcasting.net/p/wcbe/files/js/js_P9u0bgloveAIlc2kutVCUB_xMaRV3YHWhSVHD3IN5tM.js"></script>
<script type="text/javascript" src="http://mediad.publicbroadcasting.net/p/wcbe/files/js/js_-WcrGf3pH5GnSWA1Y-B28tyjknNjFr4asJklCZQ5NUA.js"></script>
<script type="text/javascript" src="http://mediad.publicbroadcasting.net/p/wcbe/files/js/js_ZcZajqjC7KCS8_A2dOG5Y53mBT4KJLE7BiKX15HUv7g.js"></script>
<script type="text/javascript" src="//www.googletagservices.com/tag/js/gpt.js"></script>
<script type="text/javascript" src="http://mediad.publicbroadcasting.net/p/wcbe/files/js/js_RUYB4OMUm_eNE6Pdz86qwDHYdVNFwB-moT_BsYB-eJc.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function() {var ga = document.createElement("script");ga.type = "text/javascript";ga.async = true;ga.src="//stream.publicbroadcasting.net/analytics/aabx.js";var s = document.getElementsByTagName("script")[0];s.parentNode.insertBefore(ga, s);})();
//--><!]]>
</script>
<script type="text/javascript" src="http://mediad.publicbroadcasting.net/p/wcbe/files/js/js_yXlS33NQjP7sM3z_EmCiiPl-M-UILqOo9fg9anfS09s.js"></script>
<script type="text/javascript">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</script>
    <meta name="viewport" content="width=device-width">
  </head>

  <body class="html not-front not-logged-in page-node page-node- page-node-107414 node-type-post" >
    <header role="banner" class="header">
  <div class="skiptocontent"><a href="#main-content">skip to main content</a></div>
    <div class="region region-header">
    <div id="block-baby-bear-baby-bear-header" class="block block-baby-bear">

    
  <div class="content">
    
<div class="header-region-outer">
  <section class="header-region-inner row">
    <div class="branding large-12 columns">
      <div class="brand-inner-wrapper">
        <a href="/" rel="home" class="logo" title="WCBE 90.5 FM Home"><img typeof="foaf:Image" src="http://mediad.publicbroadcasting.net/p/wcbe/files/201508/logo_fid.png" alt="WCBE 90.5 FM logo" title="WCBE 90.5 FM Home" /></a>         <div class="tagline">
                  </div>
      </div>
      <div class="header-utility">
        <a class="trigger-nav" href="#">
          <span class="icon-list"></span>
          <span class="menu-text">Site Menu</span>
        </a>
        <a class="give" href="https://wcbe.blackbaudondemand.com/sslpage.aspx?pid=298" >
  DONATE</a>
      </div>
    </div>
  </section>
</div>
  </div>
</div>
  </div>
</header>
    <div class="nav-wrapper mobile">
      <nav>
        <div class="top-bar contain-to-grid" data-topbar>
          <ul class="title-area">
            <li class="toggle-topbar menu-icon">
              <a href="#">Menu</a>
            </li>
          </ul>
          <section class="top-bar-section">
            <div class="table-queue" id="table-queue-fleximenu">
  <ul  class="menu dropdown">
<li>
<a href="/">Home</a>
</li>
<li class="dd has-dropdown not-click">
<a href="/about">About</a>
<ul  class="dropdown">
<li class="left">
<a href="http://wcbe.org/cpb-telling-public-radios-story-wcbes-chapter-fiscal-year-2016">CPB: Telling Public Radio&#039;s Story</a>
</li>
<li class="left">
<a href="/contact">Contact</a>
</li>
<li class="left">
<a href="/Directions">Directions</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="/programs">Programs</a>
<ul  class="dropdown">
<li class="left">
<a href="/term/broadcast-bits">Broadcast Bits</a>
</li>
<li class="left">
<a href="http://wcbe.org/programs/you-inc">Locally Produced Programs</a>
</li>
<li class="left">
<a href="http://wcbe.org/schedule/wcbe">Full Radio Schedule</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="/news">News</a>
<ul  class="dropdown">
<li class="left">
<a href="/term/business">Business</a>
</li>
<li class="left">
<a href="/term/education-0">Education</a>
</li>
<li class="left">
<a href="/term/health">Health</a>
</li>
<li class="left">
<a href="http://wcbe.org/npr-news">NPR News</a>
</li>
<li class="left">
<a href="/term/science-technology">Science + Technology</a>
</li>
<li class="left">
<a href="/term/sports">Sports</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="/programs/genre/music">Music</a>
<ul  class="dropdown">
<li class="left">
<a href="/category/music">News + Reviews</a>
</li>
<li class="left">
<a href="/search_playlists">Playlists</a>
</li>
<li class="left">
<a href="http://wcbe.org/programs/live-studio-replay">Live From Studio A REPLAY</a>
</li>
<li class="left">
<a href="/topic/studio-sessions">Studio A Sessions</a>
</li>
<li class="left">
<a href="http://www.youtube.com/user/WCBE905?feature=watch">Youtube</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="/term/arts">Arts + Life</a>
<ul  class="dropdown">
<li class="left">
<a href="/term/food">Food</a>
</li>
<li class="left">
<a href="/term/games-leisure">Games + Leisure</a>
</li>
<li class="left">
<a href="/term/literature">Literature</a>
</li>
<li class="left">
<a href="/term/movies">Movies</a>
</li>
<li class="left">
<a href="http://wcbe.org/community-calendar#stream/0">WCBE Events Calendar</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="http://wcbe.org/post/shop-support-page">Shop &amp; Support</a>
<ul  class="dropdown">
<li class="left">
<a href="http://www.cardonationwizard.com/wcbe/info/car-donation-columbus-oh.html">Car Talk Vehicle Donation</a>
</li>
<li class="left">
<a href="http://wcbe.blackbaudondemand.com/page.aspx?pid=298">Donate</a>
</li>
<li class="left">
<a href="http://wcbe.org/post/2016-fall-fund-drive-premium-levels">Levels</a>
</li>
<li class="left">
<a href="http://wcbe.blackbaudondemand.com/page.aspx?pid=290">Member Login</a>
</li>
<li class="left">
<a href="/topic/membership-news">Membership News</a>
</li>
<li class="left">
<a href="http://wcbe.org/post/shop-support-page">Shop + Support</a>
</li>
<li class="left">
<a href="/topic/vip-benefits">VIP Benefits</a>
</li>
</ul>
</li>
<li>
<a href="/search/google">Search</a>
</li>
<li>
<a href="http://www.cardonationwizard.com/wcbe/info/car-donation-columbus-oh.html">Donate Your Car</a>
</li>
</ul>
</div>
          </section>
        </div>
      </nav>
    </div>
      <div class="region region-persistent">
    <div id="block-triton-player-triton-player" class="block block-triton-player">

    
  <div class="content">
    <div id="triton-player" class="triton-wrapper">
  <div class="triton-player-container">
    <div class="triton-left">
      <td-player
  id="td-player"
  type="bar"
  autostart="false"
  station="WCBEFM"
  renderingmode="Html5,Flash"
  geotargeting="false"
  primarycolor="#bbccdd"
  secondarycolor="#4a565f"
  highlightcolor="#5599bb"
  leaderboard="companionLeaderBoard"
  onappready="appReady"
  onstreamstart="onStreamStart"
  onstreamstopped="onStreamStopped">
</td-player>
<div class="stream-program-container">
  <div class="stream-program-box">
    <div class="stream-program-header">WCBE</div>
    <div class="stream-program-name"></div>
    <div class="stream-program-nextinfo"></div>
  </div>
</div>
    </div>
    <div class="triton-more-toggle">
      <div class="triton-player-btn" role="button" aria-label="Expand/Collapse">
        <svg xmlns="http://www.w3.org/2000/svg" id="btn-open" class="toggle-arrow open" width="20px" height="11.7px" viewBox="0 0 20 11.7" preserveAspectRatio="xMinYMin">
          <path fill="#7F95A4" d="M19.5,3.4c-0.7,0.7-8.1,7.8-8.1,7.8c-0.4,0.4-0.9,0.6-1.4,0.6c-0.5,0-1-0.2-1.4-0.6c0,0-7.4-7-8.1-7.8
    c-0.7-0.7-0.8-2,0-2.8c0.8-0.8,1.8-0.8,2.7,0L10,7.1l6.7-6.5c0.9-0.8,2-0.8,2.7,0C20.2,1.4,20.2,2.7,19.5,3.4z"></path>
        </svg>
      </div>
    </div>
  </div>
  <div class="stream-selector-container">
    <div class="row collapse">
      <div class="stream-song-container">
        <div class="stream-song-box">
          <div class="stream-song-artwork"></div>
          <div class="stream-song-trackname"></div>
          <div class="stream-song-artist"></div>
          <div class="stream-song-collection"></div>
        </div>
      </div>
      <div class="stream-selector-links small-12 column">
        <ul class="stream-list">
                      <li>
  <a href="" class="triton-stream-selector-link"
     data-stream-name="WCBE"
     data-stream-key="WCBEFM"
     data-stream-ucs="5187efb6e1c85479698fb0cf">
    <div class="stream-indicator">
      <div class="triton-stream-inactive" title="not-playing"></div>
      <div class="triton-stream-active" title="playing">
        <span class="stream-activebar"></span>
        <span class="stream-activebar"></span>
        <span class="stream-activebar"></span>
      </div>
    </div>
    <div class="stream-selector-stream-summary">
      <div class="stream-selector-stream-name">
        WCBE      </div>
      <div class="stream-selector-program-name"></div>
    </div>
  </a>
</li>
                  </ul>
      </div>
    </div>
    <div class="companion-leaderboard-container">
  <div class="row">
    <div class="small-12 column">
              <div id="companionLeaderBoard" class="companionLeaderBoard"></div>
          </div>
  </div>
</div>  </div>
</div>
  </div>
</div>
  </div>
    <div id="page-wrapper">
            <div id="page-document" role="document" class="page">
  <div class="nav-wrapper">
    <nav>
      <div class="top-bar contain-to-grid" data-topbar>
        <ul class="title-area">
          <li class="toggle-topbar menu-icon">
            <a href="#">Menu</a>
          </li>
        </ul>
        <section class="top-bar-section">
          <div class="table-queue" id="table-queue-fleximenu">
  <ul  class="menu dropdown">
<li>
<a href="/">Home</a>
</li>
<li class="dd has-dropdown not-click">
<a href="/about">About</a>
<ul  class="dropdown">
<li class="left">
<a href="http://wcbe.org/cpb-telling-public-radios-story-wcbes-chapter-fiscal-year-2016">CPB: Telling Public Radio&#039;s Story</a>
</li>
<li class="left">
<a href="/contact">Contact</a>
</li>
<li class="left">
<a href="/Directions">Directions</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="/programs">Programs</a>
<ul  class="dropdown">
<li class="left">
<a href="/term/broadcast-bits">Broadcast Bits</a>
</li>
<li class="left">
<a href="http://wcbe.org/programs/you-inc">Locally Produced Programs</a>
</li>
<li class="left">
<a href="http://wcbe.org/schedule/wcbe">Full Radio Schedule</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="/news">News</a>
<ul  class="dropdown">
<li class="left">
<a href="/term/business">Business</a>
</li>
<li class="left">
<a href="/term/education-0">Education</a>
</li>
<li class="left">
<a href="/term/health">Health</a>
</li>
<li class="left">
<a href="http://wcbe.org/npr-news">NPR News</a>
</li>
<li class="left">
<a href="/term/science-technology">Science + Technology</a>
</li>
<li class="left">
<a href="/term/sports">Sports</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="/programs/genre/music">Music</a>
<ul  class="dropdown">
<li class="left">
<a href="/category/music">News + Reviews</a>
</li>
<li class="left">
<a href="/search_playlists">Playlists</a>
</li>
<li class="left">
<a href="http://wcbe.org/programs/live-studio-replay">Live From Studio A REPLAY</a>
</li>
<li class="left">
<a href="/topic/studio-sessions">Studio A Sessions</a>
</li>
<li class="left">
<a href="http://www.youtube.com/user/WCBE905?feature=watch">Youtube</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="/term/arts">Arts + Life</a>
<ul  class="dropdown">
<li class="left">
<a href="/term/food">Food</a>
</li>
<li class="left">
<a href="/term/games-leisure">Games + Leisure</a>
</li>
<li class="left">
<a href="/term/literature">Literature</a>
</li>
<li class="left">
<a href="/term/movies">Movies</a>
</li>
<li class="left">
<a href="http://wcbe.org/community-calendar#stream/0">WCBE Events Calendar</a>
</li>
</ul>
</li>
<li class="dd has-dropdown not-click">
<a href="http://wcbe.org/post/shop-support-page">Shop &amp; Support</a>
<ul  class="dropdown">
<li class="left">
<a href="http://www.cardonationwizard.com/wcbe/info/car-donation-columbus-oh.html">Car Talk Vehicle Donation</a>
</li>
<li class="left">
<a href="http://wcbe.blackbaudondemand.com/page.aspx?pid=298">Donate</a>
</li>
<li class="left">
<a href="http://wcbe.org/post/2016-fall-fund-drive-premium-levels">Levels</a>
</li>
<li class="left">
<a href="http://wcbe.blackbaudondemand.com/page.aspx?pid=290">Member Login</a>
</li>
<li class="left">
<a href="/topic/membership-news">Membership News</a>
</li>
<li class="left">
<a href="http://wcbe.org/post/shop-support-page">Shop + Support</a>
</li>
<li class="left">
<a href="/topic/vip-benefits">VIP Benefits</a>
</li>
</ul>
</li>
<li>
<a href="/search/google">Search</a>
</li>
<li>
<a href="http://www.cardonationwizard.com/wcbe/info/car-donation-columbus-oh.html">Donate Your Car</a>
</li>
</ul>
</div>
        </section>
      </div>
    </nav>
  </div>

  <div id="player" class="player">
      </div>

  
  
  
  
  <div class="row">
    <main id="content" role="main" class="main-content small-12 columns">
      <article class="story">
        <a id="main-content"></a>
        
                                    
        
        
        
        
        
        
                    <div class="region region-content">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    <div id="node-107414" class="node node-post node-promoted full row" about="/post/comeys-removal-started-whirlwind-week-politics" typeof="sioc:Item foaf:Document">
  <div class="small-12 columns">
        
    
    <h1 itemprop="name" class="post-title">
      Comey&#039;s Removal Started A Whirlwind Week Of Politics    </h1>

  	
    
          <div class="by-date">
        <span class="submitted"><span property="dc:date dc:created" content="2017-05-13T18:52:00-04:00" datatype="xsd:dateTime" rel="sioc:has_creator"><span class="submitted-label">By</span> <span class="name"><a href="/people/ron-elving" rel="author">Ron Elving</a></span></span></span>
        <i class="bullet">&#8226;</i>
        <span class="pub-date">1 hour ago</span>
      </div>
    
    <div class="row">
      <div class="large-2 columns sharing-and-programs">
        
        <div class="social-share clearfix"><a href="http://twitter.com/intent/tweet?url=http%3A%2F%2Fwww.tinyurl.com%2Fma2sogp&amp;text=Comey%27s%20Removal%20Started%20A%20Whirlwind%20Week%20Of%20Politics" class="social-share-item twitter" title="Tweet" target="_blank">Tweet</a><a href="http://facebook.com/sharer.php?u=http%3A%2F%2Fwww.tinyurl.com%2Fma2sogp&amp;t=Comey%27s%20Removal%20Started%20A%20Whirlwind%20Week%20Of%20Politics" class="social-share-item facebook" title="Share" target="_blank">Share</a><a href="https://plus.google.com/share?url=http%3A%2F%2Fwww.tinyurl.com%2Fma2sogp" class="social-share-item googleplus" title="Google+" target="_blank">Google+</a><a href="mailto:?subject=Comey%27s%20Removal%20Started%20A%20Whirlwind%20Week%20Of%20Politics&amp;body=http%3A%2F%2Fwww.tinyurl.com%2Fma2sogp" class="social-share-item email" title="Email" target="_blank">Email</a></div>      </div>

      <div class="medium-10 medium-pull-1 large-8 large-pull-2 columns post-body-container" >
        <div class="post-body">
          <div class="field field-name-field-image-gallery field-type-image field-label-hidden"><div class="field-items"></div></div>

<div class="audio-container">
  <div id="jp-interface--5917a4f9929f6" class="jp-interface">
    <div id="post-audio--5917a4f9929f6" class="jp-player" jp-instance="-5917a4f9929f6"></div>

    <div class="playpause">
      <a href="https://ondemand.npr.org/npr-mp4/npr/atc/2017/05/20170513_atc_washington_reset.mp4?orgId=1&amp;topicId=1014&amp;d=247&amp;p=2&amp;story=528287815&amp;t=progseg&amp;e=528287479&amp;seg=4&amp;ft=nprml&amp;f=1001" title="" class="jp-play"></a>      <a class="jp-pause"></a>
    </div>

    <div class="audio-meta">
      <div class="listen-text-box">
        <div class="listen-text">Listen </div>
        <div class="listening-text">Listening...</div>
      </div>

      <div class="jp-controls">
        <div class="jp-progress">
          <div id="seekbar" class="jp-seek-bar">
            <div id="playbar" class="jp-play-bar">
              <div class="scrubber">
              </div>
            </div>
          </div>
        </div>
      </div>

      <div class="duration-wrapper">
        <div class="jp-custom-current-time"></div>
        <span class="divider">&#47;</span>
        <div class="jp-custom-duration"></div>
      </div>

    </div>
      </div>
</div>
<div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><div class="fullattribution">Copyright 2017 NPR. To see more, visit http://www.npr.org/.<img src="https://www.google-analytics.com/__utm.gif?utmac=UA-5828686-4&amp;utmdt=Comey%27s+Removal+Started+A+Whirlwind+Week+Of+Politics&amp;utme=8(APIKey)9(MDA5MTc0MDI0MDEzMzE4MjI4ODdlOTk4MA004)" /></div> <p></p></div></div></div><div class="social-share bottom"><a href="http://twitter.com/intent/tweet?url=http%3A%2F%2Fwww.tinyurl.com%2Fma2sogp&amp;text=Comey%27s%20Removal%20Started%20A%20Whirlwind%20Week%20Of%20Politics" class="social-share-item twitter" title="Tweet" target="_blank">Tweet</a><a href="http://facebook.com/sharer.php?u=http%3A%2F%2Fwww.tinyurl.com%2Fma2sogp&amp;t=Comey%27s%20Removal%20Started%20A%20Whirlwind%20Week%20Of%20Politics" class="social-share-item facebook" title="Share" target="_blank">Share</a><a href="https://plus.google.com/share?url=http%3A%2F%2Fwww.tinyurl.com%2Fma2sogp" class="social-share-item googleplus" title="Google+" target="_blank">Google+</a><a href="mailto:?subject=Comey%27s%20Removal%20Started%20A%20Whirlwind%20Week%20Of%20Politics&amp;body=http%3A%2F%2Fwww.tinyurl.com%2Fma2sogp" class="social-share-item email" title="Email" target="_blank">Email</a></div><div id="disqus_thread"><noscript><p><a href="http://npr-wcbe.disqus.com/?url=http%3A%2F%2Fwcbe.org%2Fpost%2Fcomeys-removal-started-whirlwind-week-politics">View the discussion thread.</a></p></noscript></div>        </div>

        <div class="related">
                  </div>
      </div>
    </div>
      </div>
</div>
  </div>
</div>
  </div>
              </article>
    </main>
  </div>

      <section class="post-content">
      <div>
          <div class="region region-post-content">
    <div id="block-pi-responsive-ads-mobile-1" class="block block-pi-responsive-ads">

    
  <div class="content">
      </div>
</div>
  </div>
      </div>
    </section>
  
  <div class="bottom-ads">
    <div class="bottom-ads-inner"></div>
  </div>
</div>

<footer class="footer" role="contentinfo">
  <div class="row">
    <div class="footer-affiliate-container small-centered columns">
                  <div class="region region-footer">
    <div id="block-pi-table-queue-partnerfooter" class="block block-pi-table-queue">

    
  <div class="content">
    <div class="table-queue" id="table-queue-partnerfooter">
  <p class="partnerslabel">
  </p>
<div class="item-list"><ul class="partner-logos"><li class="first"><a href="http://www.americanpublicmedia.org/" target="_blank"><img typeof="foaf:Image" src="http://mediad.publicbroadcasting.net/p/wcbe/files/styles/partner_footer_logo/public/201508/apm-logo.png" alt="American Public Media" title="American Public Media" /></a></li>
<li><a href="http://www.bbc.co.uk/worldserviceradio" target="_blank"><img typeof="foaf:Image" src="http://mediad.publicbroadcasting.net/p/wcbe/files/styles/partner_footer_logo/public/201508/bbc-logo.png" alt="BBC World Service" title="BBC World Service" /></a></li>
<li><a href="http://www.cpb.org/" target="_blank"><img typeof="foaf:Image" src="http://mediad.publicbroadcasting.net/p/wcbe/files/styles/partner_footer_logo/public/201508/cpb-logo.png" alt="Corporation For Public Broadcasting" title="Corporation For Public Broadcasting" /></a></li>
<li><a href="http://www.npr.org/" target="_blank"><img typeof="foaf:Image" src="http://mediad.publicbroadcasting.net/p/wcbe/files/styles/partner_footer_logo/public/201508/npr-logo.png" alt="National Public Radio" title="National Public Radio" /></a></li>
<li><a href="http://www.pri.org/" target="_blank"><img typeof="foaf:Image" src="http://mediad.publicbroadcasting.net/p/wcbe/files/styles/partner_footer_logo/public/201508/pri-logo.png" alt="Public Radio International" title="Public Radio International" /></a></li>
<li class="last"><a href="http://www.prx.org/" target="_blank"><img typeof="foaf:Image" src="http://mediad.publicbroadcasting.net/p/wcbe/files/styles/partner_footer_logo/public/201508/prx-logo.png" alt="Public Radio Exchange" title="Public Radio Exchange" /></a></li>
</ul></div></div>
  </div>
</div>
<div id="block-pi-table-queue-auxiliarylinksfooter" class="block block-pi-table-queue">

    
  <div class="content">
    <div class="table-queue" id="table-queue-auxiliarylinksfooter">
  <div class="item-list"><ul class="auxiliary-links"><li class="first"><span>&copy; 2017 WCBE 90.5 FM</span></li>
<li><a href="http://wcbe.org/about-us#stream/0" target="_blank">About</a></li>
<li><a href="http://wcbe.org/contact#stream/0" target="_blank">Contact</a></li>
<li><a href="http://wcbe.org/eeo#stream/0" target="_blank">EEO</a></li>
<li><a href="http://wcbe.org/employment#stream/0" target="_blank">Employment</a></li>
<li><a href="http://wcbe.org/internships#stream/0" target="_blank">Internships</a></li>
<li class="last"><a href="http://wcbe.org/privacy#stream/0" target="_blank">Privacy</a></li>
</ul></div></div>
  </div>
</div>
  </div>
          </div>
  </div>
</footer>
      <script type="text/javascript">
  var _sf_async_config=Drupal.settings.chartbeat;
  (function(){
    function loadChartbeat() {
      window._sf_endpt=(new Date()).getTime();
      var e = document.createElement('script');
      e.setAttribute('language', 'javascript');
      e.setAttribute('type', 'text/javascript');
      e.setAttribute('src',
         (("https:" == document.location.protocol) ? "https://s3.amazonaws.com/" : "http://") +
         "static.chartbeat.com/js/chartbeat.js");
      document.body.appendChild(e);
    }
    var oldonload = window.onload;
    window.onload = (typeof window.onload != 'function') ?
       loadChartbeat : function() { oldonload(); loadChartbeat(); };
  })();
</script><script type="text/javascript" src="http://widgets.listenlive.co/1.0/tdwidgets.min.js?opstd6"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
 (function ($) { $(document).foundation({ topbar: { custom_back_text: true, back_text: 'back', mobile_show_parent_link: true } }); }(jQuery));
//--><!]]>
</script>
    </div>
  <script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"15ba4da3e8","applicationID":"1108724","transactionName":"NlMBMhAECEZRAU1eDg8ZIgUWDAlbHwxWUwQ+RgIBBzoQXFUV","queueTime":0,"applicationTime":298,"atts":"GhQCRFgeG0g=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
